double arrow

Формулы в MS Excel

3

Табличный процессор MS Excel предназначен для реализации различных вычислений. Вычисления организуются с помощью формул.

Любая формула MS Excel начинается со знака "=". Формулу можно определить следующим образом.

1) константа или ссылка на ячейку является формулой; при этом константа может быть записана без знака "=";

2) если А и В – формулы, то новыми формулами будут:

=А+В (сумма формул является формулой);

=А-В (разность формул является формулой);

=А*В (произведение формул является формулой);

=А/В (частное формул является формулой);

=A<B, =A<=B, =A=B, =A<>B, =A>B, =A>=В (неравенство с любыми двумя формулами также является формулой);

любая функция, аргументами которой являются формулы (или формула, либо у этой функции отсутствуют аргументы), также будет формулой;

3) других формул нет.

После записи формулы в соответствующую ячейку выводится результат вычислений по этой формуле (если в меню Сервис>Параметры…>Вид не установлен флажок в поле "Формула").

При записи формулы может возникнуть та или иная ошибка, которая получается либо в результате использования недопустимых символов при записи самой формулы, несоответствия скобок в выражении или как результат некорректного выполнения вычислений. Перечень некоторых часто встречающихся ошибок приведен в следующей таблице:




Результат Причина
#ДЕЛ/0! ноль в знаменателе дробного выражения
#ЗНАЧ! недопустимый (посторонний) символ в арифметическом выражении
#ИМЯ? недопустимая ссылка на ячейку (возможно, эта ссылка записана с использованием буквам кириллицы) либо записано имя несуществующей функции или имя функции, у которой нет аргументов, записано без скобок
#ЧИСЛО! недопустимый аргумент функции (например, отрицательное число под корнем или под знаком логарифма)

Некоторые ошибки MS Excel предлагает исправить, если "видит", что формула записана "почти правильно". Например, если обнаружено несоответствие скобок. Формула, предлагаемая MS Excel, может отличаться от той, которую первоначально желал ввести пользователь, поэтому всегда есть возможность либо отказаться от предлагаемого варианта формулы, либо подтвердить его. Например:

Формула, которую требуется ввести Формула, введенная пользователем Вариант, предлагаемый MS Excel
=(A1+B1)/C1 =(A1+B1/C1 =(A1+B1/C1)

Вариант, который предложен программой, с точки зрения правил записи MS Excel не содержит ошибок, но отличается от требуемого. Поэтому в данном случае следует отказаться от предлагаемого программой варианта и попытаться внести исправления самостоятельно.

Если основная формула не содержит ошибок, но ссылается на другую формулу, которая записана с ошибкой, то и основная формула выведет ту же ошибку. Внесение исправлений во второй, "внутренней", формуле устранит ошибку и в основной формуле. Подобные ошибки обычно называются "наведенными".



При выполнении операции автозаполнения может происходить (а может и не происходить) настраивание формулы. Это зависит от того, содержит ли формула ссылки на ячейки и как эти ссылки записаны. Исключение могут составлять такие функции, как, например СТРОКА() и СТОЛБЕЦ(), которые не содержат ссылки на ячейки, но будут изменять свои значения при автозаполнении: первая – при вертикальном, вторая – при горизонтальном.

Схема "работы" процесса настраивания формулы при вертикальном автозаполнении приведена в следующей таблице (вычисление значения кубического корня на отрезке [-2;2] с шагом 0,2):

  A B C
xn xk h
-2 0,2
x y  
=A2 =ЕСЛИ(A4=0;0;EXP(LN(ABS(A4))/3)*A4/ABS(A4))  
=A4+C$2 =ЕСЛИ(A5=0;0;EXP(LN(ABS(A5))/3)*A5/ABS(A5))  
=A5+C$2 =ЕСЛИ(A6=0;0;EXP(LN(ABS(A6))/3)*A6/ABS(A6))  
 
=A23+C$2 =ЕСЛИ(A24=0;0;EXP(LN(ABS(A24))/3)*A24/ABS(A24))  

В приведенном примере в столбце А записаны формулы со ссылкой, содержащей абсолютную строку C$2; по таким ссылкам формулы не настраиваются в вертикальном направлении. При выполнении горизонтального автозаполнения формула не будет настраиваться по ссылкам, записанным с абсолютными столбцами (например, $C2). Если же адрес ячейки, на которую ссылается формула, содержит абсолютные и строку и столбец (например $C$2), то по такой ссылке формула не будет настраиваться ни в каком из направлений.





3




Сейчас читают про: