double arrow

Примеры


Пример 1. Даны две простые дроби. Составить алгоритм получения дроби, являющейся результатом их деления.

Решение. В алгебраической форме решение задачи выглядит следующим образом:

.

Исходными данными являются четыре целые величины: а, b, с, d. Результат - два целых числа m и n.

       
 
   
алг деление дробей целa, b, c, m, n, d нач ввод a, b, c, d m := a´d n := b´c вывод “Числитель=”, m вывод “Знаменатель=”, n кон
 


       
   
 
 


Тест: a = 3, b=4, c=5, d=6.

Результат: m = 18, n = 20.


Пример 2. Даны две переменные величины X и Y. Требуется произвести между ними обмен значениями. Обмен происходит через промежуточную переменную Z.

ввод X,Y

Z:=X

X:=Y

Y:=Z

вывод X, Y

Тест: x = 3, y = -7.

Результат: x = -7, y = 3.

 
 

Пример 3. Даны три вещественных числа А, В, С. Найти наибольшее среди них.

Решение.1 способ.

Сначала определяется большее среди двух значений А и В, затем большее между найденным зна­чением и величиной С. Алгоритм имеет структуру двух пос­ледовательных ветвлений.


Тест: a = 3, b = 6, c = 2.

Результат: D = 6.


2 способ. Задача решена с помощью вложенных ветвлений.




Пример 4. Дано целое положительное число N. Вычислить факториал этого числа: N! = 1 * 2 * 3 * ... * N

Решение. Задача решается c помощью циклического алгоритма. Составим два варианта алгоритма: цикла с параметром и с применением цикла с предусловием.

       
 
   
алг Факториал 2 целF, N, R нач ввод N F:=1 дляRот1доN повторять нц F:=F´ R кц вывод “Факториал=”, F кон
 


Тест: N = 5.

Результат: факториал F = 120.


       
 
   
алг Факториал 1 целF, N, R нач ввод N F:=1 R:=1 покаR£N,повторять нц F:=F´R R:=R+1 кц вывод “Факториал=”, F кон
 


 
 







Сейчас читают про: