double arrow

Математические функции

1

Работа с математическими и статистическими функциями Excel

 

Цель работы: научиться работать с Мастером функций, проводить анализ данных.

Содержание работы:

1. Использование Мастера функций.

2. Анализ статистических данных.

3. Инструменты пакета анализа.

Порядок выполнения работы:

1. Изучить методические указания.

2. Выполнить задания.

3. Оформить отчет и ответить на контрольные вопросы.

МЕТОДИЧЕСКИЕ УКАЗАНИЯ

Математические функции

 

MS EXCEL обеспечивает 10 разных категорий функций: математические/тригонометрические, инженерные, логические, текстовые, статистические, функции категории дата/время, функции для работы с базами данных/списками, финансовые, информационные и функции категории ссылки/массивы.

Программа EXCEL содержит более 400 встроенных функций, которые можно выбрать с помощью Мастера функций.

Формулы, содержащие функции, можно вводить непосредственно в ячейку, в строку формул или создавать с помощью Мастера функций .

Для вызова Мастера функций необходимо выбрать команду Вставить функциюfx из меню Формулы или нажать на панели инструментов формула кнопку .

После её нажатия появится окно Мастера функций (рисунок 3.1).

 

 

Рисунок 3.1 – Запуск Мастера функций

В открывшемся диалоговом окне выберите категорию и имя функции, а затем в полях с соответствующими подсказками введите аргументы (рис. 3.2). После нажатия кнопки ОК, готовая функция появится в строке формул

Вызов функции состоит в указании в формуле имени функции, после которого в скобках указывается список параметров (аргументов). Отдельные параметры (аргументы) разделяются в списке точкой с запятой.

Рисунок 3.2 – Диалоговое окно Аргументы функции СРЗНАЧ (A1:A10)

 

В качестве аргумента может использоваться число, адрес ячейки или произвольное выражение, для вычисления которого также могут использоваться функции.

Аргументы функций:

1) числовые константы, например, функция ПРОИЗВЕД(2;3) вычисляет произведение чисел 2 и 3, т.е. 2·3.

2) ссылки на ячейки и блоки ячеек (функция ПРОИЗВЕД (А1;С1:СЗ) вычисляет произведение содержимого ячеек А1,С1,С2иС3, т.е.А1·С1·С2·СЗ.

3) текстовые константы (заключенные в кавычки).

4) логические значения.

5) массивы.

6) имена ссылок, например, если ячейке А10 присвоить имя СУММА –последовательность команд Формулы \ Присвоить имя... – рисунок 3.3),а блоку ячеек В10:Е10 – имя ИТОГИ, то допустима следующая запись: =СУММ(СУММА;ИТОГИ).




7) смешанные аргументы, например,

 =СРЗНАЧ (Группа;АЗ;5*3)

 

Рисунок 3.3 – Присвоение имени ячейке или блоку ячеек

Пример 1. Вычислить значения функции

Y=ex*sin (x)                 для -1£ x £1           Dx=0.1

1. Заполним столбец Азначениями аргумента функции. Чтобы не вводить их вручную, применим следующий прием. Введите в ячейку А1 начальное значения аргумента (-1). Во вкладке Главная> Редактированиевыберите кнопку Заполнить, затем Прогрессия и в открывшемся диалоговом окне укажите предельное значение (1), шаг(0,2) и направление По столбцам (рисунок 3.4). После нажатия кнопки ОКв столбце А будут введены все значения аргумента

 

Рисунок 3.4 – Автозаполнение ячеек

2.  В ячейку В1 введите формулу =exp(А1)*sin(A1). Размножьте эту формулу на остальные ячейки столбца В, ухватив левой мышью маркер заполнения (черный квадратик в правом нижнем углу рамки выделенной ячейки В1) и протащив маркер до конца изменения аргумента. В итоге будут вычислены соответствующие значения функции.

Логические функции

Принцип действия большинства логических функций EXCEL заключается в проверке некоторого условия и выполнения в зависимости от него тех или иных действий.



Так, функция ЕСЛИ выполняет проверку условия, задаваемого первым аргументом логич_выр:

=ЕСЛИ(логич_выр; знач_да; знач_нет) и возвращает знач_да, если условие выполнено (ИСТИНА), и знач_нет, противном случае (ЛОЖЬ).

Например:

=ЕСЛИ(А6<10;5;10).

Если значение в ячейке А6<10, то функция вернет результат 5, а иначе – 10.

=ЕСЛИ(B4>80;”Сданы”;”Не сданы”).

Если значение в ячейке B4>80, то в ячейке с приведенной формулой будет записано ”Сданы”, иначе – ”Не сданы”.

=ЕСЛИ(СУММ(А1:А10)>0;СУММ(В1:В10);0).

Если сумма значений в столбце А1:А10 больше 0, то вычислится сумма значений в столбце В1:В10, в противном случае результат – 0.

Дополнительные логические функции

=И (логич_выр1;логич_выр2)

=ИЛИ (логич_выр1;логич_выр2)

=НЕ (логич_выр)

позволяют создавать сложные условия, например:

=ЕСЛИ (И(СУММ(А1:А10)>0;СУММ(В1:В10)>0);СУММ (A1:B10);0).

Если суммы и в столбце А1:А10 и в столбце В1:В10 положительны, то вычислить суму значений в ячейках А1:В10, иначе – 0.

Заказать ✍️ написание учебной работы
Поможем с курсовой, контрольной, дипломной, рефератом, отчетом по практике, научно-исследовательской и любой другой работой
1

Сейчас читают про: