double arrow

Данные в ячейках таблицы

2

Данные для табличных процессоров - это информация, со­держащаяся в ячейках таблицы, представленная в символь­ной форме. Содержимым ячейки электронной таблицы может быть число, формула или текст. Частным случаем формулы является переменная (имя ячейки). Более общим - арифме­тическое или логическое выражение. Текстовый процессор должен «знать», какого типа данное хранится в конкретной ячейке таблицы для того, чтобы правильно интерпретировать ее содержимое. Так, например, признаком текстовых данных является символ ' (апостроф). Тип данных определяется множеством значении, принимаемых величиной, и совокуп­ностью операций, применимых к величинам. Отсюда, напри­мер, следует, что нельзя применять арифметические операции к ячейкам таблицы, в которых хранится текстовая информа­ция. Основной набор типов данных в MS Ехсеl практически тот же, что и в базах данных: он включает числовой; символьный, логический типы и тип «дата».

Текст - любая последовательность символов, введенных после апострофа (одинарной кавычки). Кроме того, в качест­ве текста воспринимается любая символьная последователь­ность, которая не может быть воспринята как число или формула. Иначе говоря, если при вводе числа вы допустили ошибку или при вводе формулы пропустили знак «=», то введенная информация воспримется как текст.

Числа разделяются на целые и вещественные. Вещест­венные числа можно записывать двумя способами: в форме с фиксированной запятой и в экспоненциальной форме (в фор­ме с плавающей запятой).

Запись числовой константы с фиксированной запятой предполагает, что число содержит целую и дробную части, разделенные десятичной запятой. Например, число 3,1415 так и записывается в Excel. При записи числа в экспоненци­альной форме сначала записывается мантисса, затем латин­ская буква Е (прописная или строчная), после нее порядок. Мантисса может быть записана как целая константа или константа с фиксированной запятой, а порядок - только как целая двузначная константа. Числовая константа в экс­поненциальной форме трактуется как мантисса, умножен­ная на 10 в степени, равной порядку. Например, числа0,0001 и 1 000 000 могут быть записаны следующим обра­зом: 1Е-4 или 0,1е-3 и 1е6 или 1Е+6.

В MS Ехсеl при употреблении точки в записи числа это число интерпретируется как дата. Например, 3.05.99 вос­принимается как 3 мая 1999 года.

Формулы (выражения). В электронных таблицах исполь­зуются два вида формул: арифметические и логические. Ре­зультатом вычисления по арифметической формуле являет­ся число, по логической формуле - логическая величина(истина или ложь). Существуют определенные правила за­писи формул. Эти правила аналогичны тем, что используют­ся в языках программирования.

Арифметические формулы составляются из констант, переменных, знаков операций, функций, круглых скобок. Ввод формул в MS Excel начинается со знака «=» Примеры формул:

=2,5*(G5+G2) =КОРЕНЬ(В4Л2-4*В3*В5 =СУММ(СI0:С20)

Здесь символ «*» - знак умножения; «^». - знак возве­дения в степень. Порядок вычисления выражений соответ­ствует традиционным приоритетам выполнения арифме­тических операций, с учетом расстановки скобок. В русифи­цированных версиях Excel КОРЕНЬ - функция квадратного корня, СУММ - функция суммирования. В MS Excel зало­жена очень большая библиотека функций. Вставка функ­ций в формулы производится по команде Вставка + Функ­ция или через соответствующую кнопку на панели нструментов.

Логические выражения строятся с помощью операций отно­шения «<, >, =, <=, >=,) и логических операций (логическое И, логическое ИЛИ, логическое отрицание НЕ). Результатом вы­числения логического выражения являются логические вели­чины «истина» или «ложь». С логическими выражениями вы уже встречались при работе с базами данных.

Особенность логических выражений для электронных таблиц заключается в том, что логические операции исполь­зуются как фупкции: сначала записывается имя логической операции: И, ИЛИ, НЕ, а затем в круглых скобках перечис­ляются логические операнды. Например, логическое выра­жение

И(Аl>0, Аl<l)

соответствует математической системе неравенств: 0<А1 < 1.

С помощью логических выражений, в частности, задаются условия, проверку которых осуществляет условная функция. Если в ячейку заносится условная функция, то на экране ото­бражается результат ее вычисления, т. е. то или иное значе­ние в зависимости от условия, заданного логическим выра­жением. Условная функция имеет такую структуру:

ЕСЛИ <условие>; <действие1>; <действие2>.

Если условие истинно, то выполняется <действие 1> , иначе <действие2> .

Пример: пусть в ячейке Е2 электронной таблицы с ин­формацией о сдаче вступительных экзаменов абитуриен­том хранится полученная им сумма баллов. Действует сле­дующее правило: если сумма баллов не меньше 13, то он принимается в университет. Тогда в ячейку -F2 заносится формула:

=ЕСЛИ(Е2>=13; "принят"; "не принят")

в режиме отображения значений в этой ячейке появится слово «принят» или «не принят», В зависимости от резуль­тата экзаменов.

Условная функция может иметь вложенную структуру. Пусть в этом же вузе действует следующее правило: если абитуриент набрал 12 баллов, то его принимаю т в качестве кандидата (иногда еще встречается такая категория). Тогда в ячейку F2 нужно занести формулу:

=ЕСЛИ(Е2>=13; "принят"; ЕСЛИ(Е2=12,"принят кандидатом"; "не принят"))

О некоторых других возможностях MS Excel вы узнаете в следующих параграфах.

Коротко о главном

Табличный процессор MS Excel входит в состав пакета прикладных программ Мiсrоsоft Office, работающего под управлением операционной системы Windows.

Основные режимы работы: готовность, ввод, правка; в ис­ходном состоянии ЭТ находится в режиме отображения зна­чений; через главное меню реализована иерархическая сис­тема команд.

Основные типы данных: числа, тексты, формулы, .дата.,

логические значения.

MS Ехсеl обладает богатой библиотекой функций.

2

Сейчас читают про: